Routing Information Protocol
RIP(Routing Information Protocol)
It sends the complete routing table out to all the active interface every 30 seconds. RIP only uses hop count to determine the best way to the remote network. Maximum hop count is 15.
RIP Version 1, which means all the devices in the network must use the same subnet mask. Doesn’t send updates with subnet mask information.
RIP Version 2, does send information about the subnet mask.
RIP Routing Command:
Version 1:
Router(config)#router rip
Router(config-router)#network <Source Network Address>
Version 2:
Router(config)#router rip
Router(config-router)#network <Source Network Address>
Router(config-router)#version 2
? Consider the Diagram given below dynamic routing.
Step1: Assign IP address, subnet mask and Gateway to the PCs.
Step2:
In Router 1:
Router>enable
Router#config terminal
Router(config)#int f0/0
Router(config-if)#ip address 10.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#int s2/0
Router(config-if)#ip address 12.0.0.1 255.0.0.0
Router(config-if)#clock rate 64000
Router(config-if)#no shutdown
Router(config-if)#exit
In Router 2:
Router>enable
Router#config terminal
Router(config)#int f0/0
Router(config-if)#ip address 11.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#int s2/0
Router(config-if)#ip address 12.0.0.2 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Step:3
In Router 1: Enabling RIP routing.
Router(Config)#router rip
Router(Config-router)#network 10.0.0.0
Router(Config-router)#network 12.0.0.0
Router(Config-router)#exit.
In Router 2: Enabling RIP routing.
Router(Config)#router rip
Router(Config-router)#network 11.0.0.0
Router(Config-router)#network 12.0.0.0
Router(Config-router)#exit
Open Shortest Pathway First
OSPF(Open Shortest Pathway First):
It has unlimited hop count
Uses process id and area value.
What is OSPD area?
Is a group of contiguous networks or routers.All router in the same area share a common Area ID. Because a router can be a member of more than one area a time, the Area ID is associated with the specific interface on the router
What is Process_ID?
Is used to differentiate between different OSPF process running on the router. Note that this number do not need to match between different routers.
OSPF Routing Command:
Router(config)#router ospf process_ID
Router(config-router)#network IP_address wildcard_mask area area_#
? Consider the Diagram given below dynamic routing.
Step1: Assign IP address, subnet mask and Gateway to the PCs.
Step2:
In Router 1:
Router>enable
Router#config terminal
Router(config)#int f0/0
Router(config-if)#ip address 10.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#int s2/0
Router(config-if)#ip address 12.0.0.1 255.0.0.0
Router(config-if)#clock rate 64000
Router(config-if)#no shutdown
Router(config-if)#exit
In Router 2:
Router>enable
Router#config terminal
Router(config)#int f0/0
Router(config-if)#ip address 11.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#int s2/0
Router(config-if)#ip address 12.0.0.2 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Step:3
In Router 1: Enabling OSPF routing.
Router(Config)#router ospf 10
Router(Config-router)#network 10.0.0.0 0.255.255.255 area 7
Router(Config-router)#network 12.0.0.0 0.255.255.255 area 7
Router(Config-router)#exit.
In Router 2: Enabling OSPF routing.
Router(Config)#router ospf 10
Router(Config-router)#network 11.0.0.0 0.255.255.255 area 7
Router(Config-router)#network 12.0.0.0 0.255.255.255 area 7
Router(Config-router)#exit
Enhanced Interior Gateway Routing Protocol
EIGRP Routing Command:
Router(config)#router eigrp <Autonomous number>
Router(config-router)#network <Source Network Address>.
? Consider the Diagram given below dynamic routing.
Step1: Assign IP address, subnet mask and Gateway to the PCs.
Step2:
In Router 1:
Router>enable
Router#config terminal
Router(config)#int f0/0
Router(config-if)#ip address 10.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#int s2/0
Router(config-if)#ip address 12.0.0.1 255.0.0.0
Router(config-if)#clock rate 64000
Router(config-if)#no shutdown
Router(config-if)#exit
In Router 2:
Router>enable
Router#config terminal
Router(config)#int f0/0
Router(config-if)#ip address 11.0.0.1 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Router(config)#int s2/0
Router(config-if)#ip address 12.0.0.2 255.0.0.0
Router(config-if)#no shutdown
Router(config-if)#exit
Step:3
In Router 1: Enabling EIGRP routing.
Router(Config)#router eigrp 100
Router(Config-router)#network 10.0.0.0
Router(Config-router)#network 12.0.0.0
Router(Config-router)#exit.
In Router 2: Enabling EIGRP routing.
Router(Config)#router eigrp 100
Router(Config-router)#network 11.0.0.0
Router(Config-router)#network 12.0.0.0
Comments
Post a Comment